Add support to install mysql 5.6 with bahmni 0.92

Description

Bahmni 0.92 comes with mysql 5.7 version by default. But few of the implementations facing issues with upgrade from bahmni 0.91 to 0.92 that includes upgrade of mysql 5.6 to 5.7.

Few of the queue queries taking lot of time load. Eg: one query used to take 2 sec to load with bahmni 0.91 and mysql 5.6. And the same queue taking almost 50 sec to load with the bahmni 0.92 and mysql 5.7. We have tested the same query with bahmni 0.92 and mysql 5.6 combination and things are working fine the way they used to be.

We also have seen few mysql community threads related to mysql 5.7 where the queries performance has come down.

As part of this card, we are also giving provision to user to install specific version of mysql with bahmni 0.92. We have introduced new ansible variable (mysql_version) to pass specific version of mysql. This configuration also includes the minor version of mysql

Also in bahmni-package repo, for bahmni-emr rpm replaced the mysql version check from 5.7 to 5.6.

Eg: mysql_version: 5.7.28 will install 5.7.28 even there is a latest version available in the repo

mysql_version: 5.6.48 will install 5.6.48 even there is a latest version available in the repo

PR link : https://github.com/Bahmni/bahmni-playbooks/pull/54/

Activity

Show:
Himabindu Thungathurty
June 16, 2020, 9:46 AM

approved the PR and got merged by

The same changes needs to be committed to master branch

Himabindu Thungathurty
June 16, 2020, 10:02 AM
Edited

The PR raised to bahmni-package has reviewed and merged by

The same needs to be committed to master branch

Assignee

Himabindu Thungathurty

Reporter

Himabindu Thungathurty

Units

None

PercentDone

None

DueTime

None

Clients

None

External issue ID

None

UAT Assignee

None

Reviewer

angshuman sarkar

Fix versions

Configure