In openerp-atomfeed-service, there is already ENUMS defined for specific feed processing jobs (org.bahmni.feed.openerp.job.Jobs).
However in code, there is mixed usage of using this enum and also (String:feedName) across the constructs. The feedName is often mixed up as feedUri, which most of the case is just a property key, which is used to actually pick up the right feed URL.
All these just cause confusion. We should be able to use just the enum everywhere and lookup of the feed URL can also be done using the enum.